Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые
числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.
- 14.02.2018 22:42
- Информатика
- remove_red_eye 3572
- thumb_up 51
Ответы и объяснения 1
Var
a,c:integer;
Begin
Writeln('Вводите числа (через Enter)');
repeat
Readln(a);
if (a0) and ((a mod 10) = 0) and ((a mod 4) = 0) then inc(c);
until a=0;
Write('Количество чисел кратных 4 и оканчивающихся на 0 равно ',c);
End.
- 15.02.2018 03:59
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.