Вопрос по информатике:
Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)
- 08.11.2017 15:57
- Информатика
- remove_red_eye 9694
- thumb_up 31
Ответы и объяснения 1
Var n,i,k:integer;
begin
write('n='); readln(n);
k:=2;
for i:=2 to n div 2 do
if n mod i = 0 then k:=k+1;
writeln('k=',k);
end.
Пример:
n=20
k=6
- 09.11.2017 19:20
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.