Вопрос по информатике:
Напишите программу для вычисления наибольшего общего делителя двух целых чисел:
а)используйте оператор repeat
б)используйте оператор while
- 12.04.2018 01:12
- Информатика
- remove_red_eye 4091
- thumb_up 14
Ответы и объяснения 1
//1. Переборный алгоритм Евклида (цикл repeat)
var a, b, с: integer;
begin
write('Введите два числа: ');
readln(a, b);
if a < b then с := a + 1 else с := b + 1;
repeat с := с - 1
until (a mod с = 0) and (b mod с = 0);
write('NOD = ', с)
end.
//2. Алгоритм с вычитанием (цикл while)
var a, b: integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
while a b do
if a > b then
a := a - b
else
b := b - a;
writeln('NOD = ', a);
end.
- 13.04.2018 20:01
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.