Вопрос по информатике:
Помогите, пожалуйста, с паскалем!
Входные данные
Вводятся 2 числа: x и d.
Выходные данные
Подсчитайте и выведите одно число - сколько раз встречается в записи натурального числа x цифра d.
Примеры
входные данные
123
2
выходные данные
1
входные данные
141
1
выходные данные
2
- 26.10.2016 16:38
- Информатика
- remove_red_eye 8809
- thumb_up 13
Ответы и объяснения 1
Var
x,d,count:integer;
begin
write('x=');
readln(x);
write('d=');
readln(d);
while x>0 do
begin
if x mod 10 = d then
count:=count+1;
x:= x div 10;
end;
writeln(count);
end.
- 27.10.2016 09:02
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.