Вопрос по информатике:
Составьте программу заполнения массива из ста чисел, со случайными значениями из диапазона от -20 до 20. Посчитайте в этом массиве количество положительный и отрицательных чисел.
- 04.09.2017 14:45
- Информатика
- remove_red_eye 4591
- thumb_up 45
Ответы и объяснения 1
Const n=100;
var x : array[1..n] of integer;
i,k1,k2 : integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
x[i]:=random(41)-20;
write(x[i],' ');
end;
writeln;
for i:=1 to n do
begin
if x[i]<0 then k1:=k1+1;
if x[i]>0 then k2:=k2+1;
end;
writeln('k1=',k1,' k2=',k2);
end.
- 05.09.2017 15:24
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.