Вопрос по информатике:
1. Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности. Пример работы программы: Входные данные Выходные данные 11 26 15 30 9 0
- 14.07.2018 13:43
- Информатика
- remove_red_eye 8928
- thumb_up 19
Ответы и объяснения 1
Var
a, s: integer;
begin
s :=0;
repeat
readln(a);
if (a mod 2 0) and (a 9) then
inc(s, a);
until a = 0;
writeln(s);
end.
- 15.07.2018 01:11
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.