Вопрос по информатике:
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом. На вход программе подается строка, состоящая не более чем из 255 символов. Выведите искомое число. паскаль
- 25.10.2016 06:31
- Информатика
- remove_red_eye 20001
- thumb_up 11
Ответы и объяснения 1
Var s : String;
Function isPali(ss : String) : Boolean;
Begin
If Length(ss)>0 then isPali:=(ss[1]=ss[Length(ss)]) and isPali(Copy(ss,2,Length(ss)-2))
else isPali:=True;
end;
Function NtoPali(ss : String) : Integer;
Begin
If isPali(ss) then NtoPali:=0 else NtoPali:=1+NtoPali(Copy(ss,2,Length(ss)-1));
end;
Begin
s:='abcdc'; // Readln(s);
Writeln(NtoPali(s));
end.
- 26.10.2016 03:03
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.