Вопрос по информатике:
В паскале составить программу:
определить делимость на 3 для четырехзначного числа.
(думаю, что надо использовать св-во делимости числа: число будет делиться на 3, если сумма цифр этого числа будет делиться на три)
- 03.09.2015 21:07
- Информатика
- remove_red_eye 15079
- thumb_up 23
Ответы и объяснения 1
var
a: 1000..9999;
a1, a2, a3, a4: 0..9; //Цифры четырехзначного числа
begin
writeln('Введите четырехзначное число');
readln(a);
a1:= a div 1000;
a2:= (a mod 1000) div 100;
a3:= (a mod 100) div 10;
a4:= a mod 10;
if (a1 + a2 + a3 + a4) mod 3 = 0 then writeln(a, ' делится на 3')
else writeln(a, ' не делится на 3');
end.
- 04.09.2015 15:59
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.