Вопрос по информатике:
Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. Через сколько минут температура воды станет ниже Nо С?
- 13.04.2018 12:45
- Информатика
- remove_red_eye 5714
- thumb_up 20
Ответы и объяснения 1
Var A, gradus, minut, N: real;
Begin
Writeln('Введите A градусов');
readln(A);
Writeln('До какой температуры остужать:');
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
A:=A*(1-0.15);
gradus:=gradus-A;
minut:=minut+1;
end;
Writeln('Кипяток остынет до ',N,' градусов через ', minut, ' минут');
readln();
end.
- 14.04.2018 01:58
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.