Вопрос по информатике:
Составить программу в Паскаль:Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.
- 18.05.2018 15:23
- Информатика
- remove_red_eye 13180
- thumb_up 45
Ответы и объяснения 1
Var b,a,c,kol:integer;
begin
writeln('введите число в десятичной системе счисления');
readln(a);
kol:=0;
while(a>=2) do begin
c:=a div 2;
b:=2*c;
b:=a-b;
writeln(b);
a:=c;
if a<2 then
writeln(a);
if a > 0 then
kol:=kol+1;
end;
writeln('количество 'kol);
end.
- 19.05.2018 00:58
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.