Вопрос по информатике:
Составьте программу в Паскаль. Седьмому классу на практике получено сдуть 1000 одуванчиков. Бригада мальчиков первый день сдуло А одуванчиков, а бригада девочек в два раза меньше. В каждый последующий день производительность мальчиков уменьшалась на 10 %,а девочек росла на 15 % по сравнению с предыдущим. Через сколько дней классы выполнит норму Вопросительный знак сколько сделают бригада мальчиков и девочек в отдельности?
- 11.06.2016 10:25
- Информатика
- remove_red_eye 4270
- thumb_up 11
Ответы и объяснения 1
Хорошая задачка! Хочется её решать в целых числах, но в условии этого не требуется.
var a,k:integer; m,d,sm,sd:real;
begin
write('A='); readln(a);
m:=a; d:=a/2;
sm:=m; sd:=d;
k:=1;
while sm+sd<1000 do
begin
m:=m*0.9; sm:=sm+m;
d:=d*1.15;sd:=sd+d;
k:=k+1;
end;
writeln('k=',k,' sm=',sm:6:2,' sd=',sd:6:2);
end.
Пример:
A=70
k=9 sm=428.81 sd=587.50
- 12.06.2016 22:06
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.