Вопрос по информатике:
НА ПАСКАЛЕ!!! 1. Написать программу которая будет выводить сумму четных цифр(пока не введете 0). 2.Программа выводит количество четных цифр. 3.Программу которая будет выводить произведение введенных чисел пока не будет введен 0.
- 19.05.2016 10:00
- Информатика
- remove_red_eye 12832
- thumb_up 13
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(t->t0).Where(t->t.IsEven).Sum)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708
begin
Writeln(ReadSeqIntegerWhile(t->t0).Where(t->t.IsEven).Count)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5
begin
Writeln(ReadSeqIntegerWhile(t->t0).Aggregate(Biginteger(1),(x,y)->x*y))
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000
- 20.05.2016 11:20
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.