Вопрос по информатике:
Помогите,пожалуйста,написать программу в Паскале
очень срочно...
Дан двумерный массив размером 4*6,заполненный целыми числами с клавиатуры.Сформировать одномерный массив,каждый элемент которого равен кол-ву элементов соответствующей строки,больших данного числа.
- 20.10.2017 21:24
- Информатика
- remove_red_eye 14588
- thumb_up 17
Ответы и объяснения 1
Var
x:real;
arr2: array [1..4,1..6] of integer;
arr1: array [1..4] of integer;
begin
writeln('Введи число для сравнения');
readln(x);
for var i:=1 to 4 do
begin
writeln('Вводим строку ',i);
for var j:=1 to 6 do
begin
writeln('Введи число ', j);
readln(arr2[i,j]);
if arr2[i,j]>x then arr1[i]:=arr1[i]+1;
end;
end;
writeln('Двумерный массив: ', arr2, ' Количество чисел больше заданного: ', arr1);
end.
- 21.10.2017 16:20
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.