Вопрос по информатике:
Задача банкомат
Написать программу:
На вход подаётся число s. Выразить данную сумму денег минимальным количеством банкнот по 500, 100, 10, 5, 2,1.
- 04.08.2018 00:12
- Информатика
- remove_red_eye 3028
- thumb_up 26
Ответы и объяснения 1
Program abc;
var a:array[1..6] of integer;
var i,s: integer;
begin
i:=0;a[1]:=500;a[2]:=100;a[3]:=10;a[4]:=5;a[5]:=2;a[6]:=1;
writeln('Введите целое число,сумму денег:');
readln(s);
while s0 do
begin
if s>=a[1] then begin
s:=s-a[1]; i:=i+1; end;
if (s>=a[2]) and (sif (s>=a[3]) and (sif (s>=a[4]) and (sif (s>=a[5]) and (sif (s>=a[6]) and (send;
Writeln('Наименьшее число купюр =',i);
end.
- 04.08.2018 04:46
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.