Вопрос по информатике:
ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО
Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.
Примеры
входные данные
2
выходные данные
- 13.02.2018 20:16
- Информатика
- remove_red_eye 7426
- thumb_up 42
Ответы и объяснения 1
Var x:integer;
begin
readln(x);
for var i:=2 to x do
if (x mod i)=0 then begin
writeln('delitel: ',i);
exit;
end;
end.
- 14.02.2018 09:44
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.