Вопрос по информатике:
Требуется поменять местами первый элемент массива с максимальным.ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000).
ВЫХОДНЫЕ ДАННЫЕ
Вывести получившийся массив. Если максимальных элементов несколько, требуется поменять первый из них.
ПРИМЕРЫ
ВВОД ВЫВОД
5
1 2 3 4 5
5 2 3 4 1
- 13.09.2017 18:10
- Информатика
- remove_red_eye 15368
- thumb_up 49
Ответы и объяснения 1
Var a:array[1..1000] of integer;
i,n,max,m:integer;
begin
write('n=');readln(n);
for i:=1 to n do read(a[i]);
max:=a[1];m:=1;
for i:=2 to n do if a[i]>max then
begin max:=a[i]; m:=i; end;
a[m]:=a[1];a[1]:=max;
for i:=1 to n do write(a[i],' ');
writeln;
end.
- 14.09.2017 17:51
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.