Вопрос по информатике:
Написать программу, выделяющую из некоторого заданного множества подмножество четных чисел. Паскаль, как можно быстрее, пожалуйста.
- 24.04.2018 06:35
- Информатика
- remove_red_eye 13879
- thumb_up 19
Ответы и объяснения 1
Var a,b:set of integer;
i,n: integer;
begin
write('кол-во элементов множества: ');
readln(n);
randomize;
for i:=1 to n do
a:=a+[random(250)];
write('элементы множества: ');
foreach i in a do
begin
write(i,' ');
if i mod 2 = 0 then b:=b+[i];
end;
writeln;
write('подмножество четных элементов: ');
foreach i in b do write(i,' ');
end.
- 25.04.2018 04:54
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.