Вопрос по информатике:
Дан одномерный массив. Найти функцию максимум+минимум. Последовательный переход с заданного по последний элемент. (Максимум) С первого по заданный пользователем (Минимум)
Написать программу на php/pascal
Помогите пожалуйста, люди добрые.
- 26.06.2015 07:49
- Информатика
- remove_red_eye 1618
- thumb_up 32
Ответы и объяснения 1
Var n,m:integer;b:boolean;
function fminmax(k:integer;d:boolean):integer;
var a:array[1..30] of integer;j,max,min:integer;
begin
for j:= 1 to 30 do begin a[j]:= random(100)-50; write(a[j]:4);end;
max:= -100;min:=100;
if b = true then
for j:= 1 to k do begin
if max < a[j] then max := a[j];fminmax:=max;end
else
for j:= n to 30 do begin
if min > a[j] then min := a[j];
fminmax:=min;end;
end;
begin
write ('Введите число < 25');Read(n);
write ('Определять max(true -да, false- нет)');Read(b);
m:= fminmax(n,b);
writeln;
if b = true then write('max = ',m)
else
write('min = ',m);end.
- 27.06.2015 06:34
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.