Вопрос по информатике:
Составьте программу, которая заполняет массив s [1..15] случайными целыми числами в диапазоне от -15 до 5 и находит количество элементов кратных 3.
- 21.11.2017 13:45
- Информатика
- remove_red_eye 11960
- thumb_up 19
Ответы и объяснения 1
Var
a:array [1..30] of integer; // тут можешь регулировать количество чисел
i,k,n:integer;
begin
k:=0;
writeln('введите количество чисел от 1 до 30');
read(n);
randomize;
for i:=1 to n do begin
a[i]:=random(16)-5;
write(a[i]:3);
end;
writeln();
for i:=1 to n do if (a[i] mod 3=0) and (a[i]0) then k:=k+1;
writeln(k);
end.
- 22.11.2017 23:49
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.