Вопрос по информатике:
Напишите программу на языке Паскаль для решения следующей задачи: Известно, что Пятачок собираясь на день рождения Иа, собрал А цветов. Придя на торжество он увидел, что Вини принес цветов в два раза больше чем он, а Сова на пять меньше чем Вини. Немного опоздавший Кролик принес на 3 цветка меньше, чем Пятачок и Вини вместе взятые. Сколько всего цветов принесли на день рождения Иа вместе Сова и Кролик?
- 21.05.2018 10:25
- Информатика
- remove_red_eye 3140
- thumb_up 44
Ответы и объяснения 1
{Всего получается A (Пятачок) + A*2 (Винни) + A*2 - 5 (Сова) + A + A*2 - 3 (Кролик) = A*8 - 8 = (A-1)*8 цветов}
var A, S: integer;
begin
read(a);
s := 8*(a-1);
write(s)
end.
- 23.05.2018 00:16
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.