Вопрос по информатике:
На языке Pascal написать программу
Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.
Задание выполнять с оператором while/
Помогите, пожалуйста
- 12.06.2017 09:14
- Информатика
- remove_red_eye 10313
- thumb_up 31
Ответы и объяснения 1
Program prog;
Uses Crt;
var n,a,x,k:integer;
begin
clrscr;
write('Введите число n = ');
readln(n);
x:=n;
while (x>0) do begin
a:=x mod 10;
x:=x div 10;
end;
while (n>0) do begin
if (n mod 10) = a then
k:=k+1;
n:=n div 10;
end;
writeln('Цифра ',a, ' встречается ', k, ' раз(а)');
end.
- 13.06.2017 02:14
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.