Вопрос по информатике:
Помогите, пожалуйста, очень прошу, срочно!!!!
1) Какие из описаний могут быть именами переменных
a) с
b) summa 2
c) book
d) 2_а
2) Какая команда служит для вывода значений переменных в Pascal-е? Приведите пример.
3) Найдите и исправьте ошибки в следующей программе:
program prim_a;
var m, n, k: integer;
begin
writeln(введите значения переменных m и n);
read(m,n, k);
writeln('(m+n+k)*5');
end.
4) Напишите программу для решения одной из двух задач:
a) Найти площадь треугольника с основанием а и высотой h.
b) Найти значение выражения:
5) Напишите программу для нахождения произведения цифр двузначного числа.
- 05.09.2016 07:23
- Информатика
- remove_red_eye 3890
- thumb_up 43
Ответы и объяснения 1
1. a; c
2. write(); writeln(). Пример: write(c) /поясняю: ln добавляется для перехода на следующую строку при выводе/
3. Ошибка - в строке "writeln(введите значения переменных m и n);" не указана переменная k. Так же не нужны кавычки в выводе, а при вводе необходимы.
Исправление:
program prim_a;
var m, n, k: integer;
begin
writeln('введите значения переменных m, n и k');
read(m,n, k);
writeln((m+n+k)*5);
end.
4. a)
program plowad;
var
a, h: real;
begin
writeln('Введите основание треугольника и высоту');
readln(a, h);
writeln('Площадь треугольника равна ', a*h/2);
end.
5. program proizvedenie;
var
a, b: integer;
begin
writeln('Введите двузначное число');
readln(a);
b:=a mod 10;
a:=a div 10;
writeln('Произведение цифр двузначного числа равно ', a*b);
end.
- 06.09.2016 19:30
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.