Вопрос по информатике:
Прошу помогите!!!
Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц – В рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета С рублей за минуту. Требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.
- 26.08.2017 05:09
- Информатика
- remove_red_eye 14688
- thumb_up 31
Ответы и объяснения 1
Var a,d:integer; b,c,p:real;
begin
write('A=');readln(a);
write('B=');readln(b);
write('C=');readln(c);
write('Разговоров за месяц: ');readln(d);
if d<=a then p:=b*d else p:=b*a+c*(d-a);
writeln('Плата за телефон=',p:5:2);
end.
Пример:
A=20
B=1.70
C=1.90
Разговоров за месяц: 25
Плата за телефон=43.50
- 27.08.2017 04:41
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.