Вопрос по информатике:
Дан текстовый файл. Составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. Вставьте в конце каждой строки количество слов и записать в новом файле.
- 11.06.2018 02:34
- Информатика
- remove_red_eye 19367
- thumb_up 7
Ответы и объяснения 1
Var s : string; finish,k,i : longint;begin assign(input,'input.txt'); reset(input); assign(output,'output.txt'); rewrite(output); finish:=0; while(finish=0) do { если finish будет 0 то программа перестанет читать текст} begin writeln('читать? если да, то 0 если нет, то 1'); readln(finish); k:=0; if finish=0 then begin readln(s); for i:=1 to length(s) do if s[i]=' ' then inc(k); end else exit; inc(k); writeln(k); end;end.
- 12.06.2018 16:32
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.