Вопрос по информатике:
Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел. ( На языке Паскаль С++)
- 09.09.2018 18:41
- Информатика
- remove_red_eye 10982
- thumb_up 50
Ответы и объяснения 1
Program z1; Var i,n,a,b,c:integer; m: array [1..1000] of integer;Begin write('Введите кол-во чисел - '); readln(n); randomize; a:=0; b:=0; c:=0; for i:=1 to n do begin m[i]:=random(100)-50; write (m[i],' '); end; for i:=1 to n do if (m[i]=0) then a:=a+1; for i:=1 to n do if (m[i]>0) then b:=b+1; for i:=1 to n do if (m[i]<0) then c:=c+1; writeln; writeln ('Кол-во нулей - ',a); writeln ('Кол-во положительных чисел - ',b); writeln ('Кол-во отрицательных чисел - ',c);End.
- 01.01.1970 00:00
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.