Вопрос по информатике:
Составить программу,которая формирует список L, включив в него по одному разу элементы,которые входят одновременно в оба списка L1 и L2.
Pascal abc.net
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 15.05.2015 16:34
- Информатика
- remove_red_eye 12205
- thumb_up 13
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1088
begin
var L1:=new List;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
- 16.05.2015 14:07
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.