Вопрос по информатике:
С помощью цикла while…do или цикла repeat…until написать программу возведения числа А в целую степень N. На языке C#.
- 01.07.2018 10:59
- Информатика
- remove_red_eye 966
- thumb_up 48
Ответы и объяснения 1
class Program {
static void Main() {
Console.Write("a= ");
string sa = Console.ReadLine();
double a = Convert.ToDouble(sa);
Console.Write("n= ");
string sn = Console.ReadLine();
int n = Convert.ToInt32(sn);
int i = 1; double b = 1;
while (i <= n) {
b *= a;
i++;
}
Console.Write(b); Console.Read();
}
}
Пример(1):
a=3
n=3
27
Пример(2):
a=2,1
n=5
40,84101
- 02.07.2018 14:35
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.