Вопрос по информатике:
Написать программу , которая считает, сколько раз последовательности из 10 чисел встречается введённое с клавиатуры число А.
- 14.02.2018 21:51
- Информатика
- remove_red_eye 18635
- thumb_up 47
Ответы и объяснения 1
Var i,k,n: integer;
a: array[1..10] of integer;
begin
k:=0; randomize;
writeln('число: '); readln(n);
writeln('последовательность из 10 элементов');
for i:=1 to 10 do
begin
a[i]:=random(50);
write(a[i],' ');
if a[i]=n then k:=k+1;
end;
writeln;
if k>0 then
writeln('число ',n,' встречается ',k,' раз')
else
writeln('числа ',n,' нет в последовательности');
readln;
end.
- 15.02.2018 15:00
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.