Вопрос по информатике:
Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, L, M: integer; begin readln(x); L:=0; M:=0; while x > 0 do begin L:= L 1; M:= M x mod 10; x:= x div 10; end; writeln(L); write(M); end.
- 09.11.2017 10:39
- Информатика
- remove_red_eye 11782
- thumb_up 19
Ответы и объяснения 1
L - счётчик (сколько раз повторяется цикл) .
L=3 - поэтому у нас должно быть трёхзначное число.
M:=m+ x mod 10. - последовательно складываем все цифры числа x, в итоге должны получить 7.
что максимальное число при таком раскладе - 700
- 01.01.1970 00:00
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.