Вопрос по информатике:
Даны целое трехзначное число N и цедое число k. написать программу, подсчитывающую сумму цифр числа N, которые больше k
- 20.09.2018 15:01
- Информатика
- remove_red_eye 10374
- thumb_up 10
Ответы и объяснения 1
Var N,k,sum : Integer;
Begin
sum:=0;
Readln(N,k);
While N>0 do
Begin
If (N mod 10)>k then sum:=sum+(N mod k);
N:=N div 10;
end;
end.
или так
Var N,k,sum : Integer;
Begin
sum:=0;
Readln(N,k);
While N>0 do
Begin
sum:=sum+(N mod 10)*Ord((N mod 10)>k);
N:=N div 10;
end;
end.
или так
Var N,k : Integer;
Function sum(N,k : Integer) : Integer;
Begin
If (N>0) and ((N mod 10)>k) then sum:=(N mod 10)+sum(N div 10,k) else sum:=0;
end;
Begin
Readln(N,k);
Writeln(sum(N,k));
end.
- 21.09.2018 20:25
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.