Вопрос по информатике:
Составьте программу позволяющую выяснить сколько раз встречается каждая буква алфавита во введенной строке s. Pascal abc Пример август вывод кол букв а=1 кол букв б=0 кол букв в=1 и т.д
- 14.02.2018 17:32
- Информатика
- remove_red_eye 13813
- thumb_up 35
Ответы и объяснения 1
Var s: string;
a: array['a'..'я'] of integer;
i: integer;
c: char;
begin
write('Введите слово: ');
readln(s);
for i := 1 to length(s) do
inc(a[s[i]]);
writeln('Количество букв ');
for c := 'а' to 'я' do
writeln(c, ': ', a[c]);
end.
- 15.02.2018 22:22
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.