Вопрос по информатике:
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое элементов этого массива.
Входные данные
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – среднее арифметическое элементов этого массива, сохранив три знака в дробной части.
- 04.09.2017 18:22
- Информатика
- remove_red_eye 3929
- thumb_up 21
Ответы и объяснения 1
Var
c:array[1..100] of integer;
i, n, k, S, a, b: integer; q: real;
begin
read(n); read(a); read(b); k:=0; S:=S;
for i:=1 to n do begin
a[i]:=random(a,b);
k:=k+1; S:=S+a[i]; write(a[i], ' '); end;
q:=S/k;
writeln(q:17:3);
end.
- 05.09.2017 05:31
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.