Вопрос по информатике:
Напишите программу, которая вводит натуральные числа a и b и вводит все простые числа в диапазоне от a до b.
Спасибо :)
- 03.09.2018 01:57
- Информатика
- remove_red_eye 2221
- thumb_up 38
Ответы и объяснения 1
Var
a, b, i, j, found: integer;
begin
readln(a, b);
for i := a to b do
begin
found := 1;
for j := 2 to round(sqrt(i + 1)) do
begin
found := found * (i mod j);
if found = 0 then break;
end;
if found 0 then write(i, ' ');
end;
end.
- 04.09.2018 07:32
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.