Вопрос по информатике:
Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет кратные 4 числа на 1
- 18.05.2016 11:03
- Информатика
- remove_red_eye 7719
- thumb_up 31
Ответы и объяснения 1
Var a:array[1..7] of integer; i:integer; n1:real;
begin
writeln('Введите 7 целых чисел');
for i:=1 to 7 do
begin
repeat
read(n1);
if (n1round(n1)) then writeln('Необходимо целое число');
until (n1=round(n1));
a[i]:=round(n1);
end;
for i:=1 to 7 do
begin
if (a[i] mod 4=0) then a[i]:=1;
end;
writeln('Полученный массив:');
for i:=1 to 7 do
write(a[i]:5);
writeln('');
end.
- 19.05.2016 04:30
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.