Вопрос по информатике:
Пожалуйста помогите написать программу по информатики для решения задачи:
В массиве рост юношей задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек.
- 20.10.2017 01:58
- Информатика
- remove_red_eye 13346
- thumb_up 24
Ответы и объяснения 1
#include
using namespace std;
int main() {
cout << "Введите массив (0, чтобы закончить):\n";
int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "
<< (sb / cb) << '\n'
<< "Средний рост девушек: "
<< (sg / cg) << '\n';
return 0;
}
- 21.10.2017 10:33
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.