Вопрос по информатике:
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
- 18.10.2017 16:37
- Информатика
- remove_red_eye 6868
- thumb_up 45
Ответы и объяснения 1
Var n,m,k,p,a:integer;
begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n0 do
begin
k:=n mod 10;
if ka then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln('m=',m);
end.
- 19.10.2017 04:25
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.