Вопрос по информатике:
Помогите написать программу на паскале: даны 2 текстовых файла. определить в каком файле больше запятых
- 25.10.2016 06:59
- Информатика
- remove_red_eye 8619
- thumb_up 15
Ответы и объяснения 1
Var f1:text;
f2:text;
s1,s2:string;
k1,k2:integer;
begin;
assign(f1,'f1.txt');
reset(f1);
while not Eof(f1) do
read(f1,s1);
close(f1);
assign(f2,'f2.txt');
reset(f2);
while not Eof(f2) do
read(f2,s2);
close(f2);
while pos(',',s1)0 do
begin;
delete(s1,pos(',',s1),1);
inc(k1);
end;
while pos(',',s2)0 do
begin;
delete(s2,pos(',',s2),1);
inc(k2);
end;
if k1>k2 then writeln('В первом');
if k2>k1 then writeln('Во втором');
if k2=k1 then writeln('Равно');
end.
- 26.10.2016 08:28
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.