Вопрос по информатике:
ПОМОГИТЕ СРОЧНО!!!
Ниже написана программа. Получив на вход число x, эта программа печатает два числа, a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9. ПОЖАЛУЙСТА С РЕШЕНИЕМ!
var x, a, b : integer;
begin
readln (x);
a := 0; b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 5);
x := x div 5;
end;
writeln (a); write (b);
end.
- 27.04.2018 06:58
- Информатика
- remove_red_eye 5389
- thumb_up 40
Ответы и объяснения 1
//Я снова предстаю в ипостаси гуманитария, не желающего ничего считать
//Сделаем так, чтобы код сам выдавал нам ответы
var x,a,b,m:integer;
begin
for m:=1 to 10000 do //m- тот же x, сохранённый для цикла
begin;
x:=m;
a := 0;
b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 5);
x := x div 5;
end;
if (a=3) and (b=9) then writeln(m);
//если программа должна вернуть подходящие нам значения, возвращаем x
end;
end.
Вывод программы:
43
83
91
Ответ:91
- 28.04.2018 16:51
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.