Вопрос по информатике:
Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ пользователя, проверяет его и выводит сообщение «Правильно!» или «Вы ошиблись» и верный результат. Pascal ABC
- 23.09.2016 10:13
- Информатика
- remove_red_eye 3429
- thumb_up 39
Ответы и объяснения 1
a,b,r:byte;
begin
randomize;
a:=Random(9)+1;
b:=Random(9)+1;
Write(a,' x ',b,' = ');
Readln(r);
if r=a*b then Writeln('Правильно!')
else Writeln('Вы ошиблись. Верный результат ',a*b)
end.
- 24.09.2016 18:07
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.