Вопрос по информатике:
Помогите, пожалуйста, составить программу!!! Паскаль.
1. Из строки символов удалить самое длинное слово (тема: строковые и символьные величины).
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 26.01.2015 00:17
- Информатика
- remove_red_eye 4454
- thumb_up 48
Ответы и объяснения 1
Var st: string;
i,begs,ind,maxs: integer;
begin
write('задайте строку: ');
readln(st);
begs:=1; maxs:=1;
for i:=1 to Length(st) do
begin
if st[i]=chr(32) then
begin
if maxs<(i-begs) then
begin
maxs:=i-begs;
ind:=begs;
end;
begs:=i+1;
end;
end;
Delete(st,ind,maxs);
writeln('новая строка: ',st);
end.
- 27.01.2015 08:39
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.