Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет
- 04.09.2017 14:52
- Информатика
- remove_red_eye 12538
- thumb_up 21
Ответы и объяснения 1
Var i,b,c:integer;
a:array[1..100] of integer;
Begin
Read(b);
I:=1;
While b0 do
Begin
A[i]:=b;
I:=i+1;
Read(b);
End;
C:=i-1;
D:=0;
B:=0;
For i:=1 to c do
If a[i]>99
Then begin b:=b+a[i]; d:=d+1; end;
If b=0
Then writeln('NO')
Else writeln(b/d);
End.
- 06.09.2017 00:15
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.