Вопрос по информатике:
Помогите плиз написать программу в паскале
Найти сумму чётных натуральных чисел в промежутке от n1 до n2.
Pascal ABC.
- 23.11.2017 00:55
- Информатика
- remove_red_eye 11269
- thumb_up 12
Ответы и объяснения 1
1. "Школьное" решение
// PascalABC.Net 3.0, сборка 1064
var
i,n1,n2:integer;
s:longint;
begin
Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
s:=0;
if n1 mod 2 = 0 then i:=n1 else i:=n1+1;
while i<=n2 do begin s:=s+i; i:=i+2 end;
Writeln('Сумма четных чисел в интервале равна ',s)
end.
Тестовое решение:
Введите интервал для вычисления суммы: 7 14
Сумма четных чисел в интервале равна 44
2. Современное решение
// PascalABC.Net 3.0, сборка 1064
var
n1,n2:integer;
begin
Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
if Odd(n1) then Inc(n1);
Writeln('Сумма четных чисел в интервале равна ',Range(n1,n2,2).Sum);
end.
- 24.11.2017 00:49
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.