Вопрос по информатике:
Напишите программу пожалуйста):
Ввести 15 целых элементов массива, элемента с нечетными номерами увеличить на 10, элементы с четными номерами уменьшить на 10. Вывести на экран
- 16.02.2015 19:07
- Информатика
- remove_red_eye 2263
- thumb_up 20
Ответы и объяснения 1
USES CRT;
VAR A:array[1..15] of integer;
i:integer;
BEGIN
CLRSCR;
{Заполняем массив}
For i:=1 to 15 do
begin
Write('Введите ',i,' элемент массива ');
Read(A[i]);
CLRSCR;
end;
{Выводим массив на экран}
For i:=1 to 15 do
Write(A[i],' ');
{К нечетным номерам массива +10 к четным -10}
For i:=1 to 15 do
if i mod 2 0 then A[i]:=A[i]+10
else A[i]:=A[i]-10;
Writeln;
{Выводим на экран измененный массив}
For i:=1 to 15 do
Write(A[i],' ');
Readln;
READLN;
END.
- 17.02.2015 13:45
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.