Вопрос по информатике:
Составьте программу для решения следующей задачи. Дано четырехзначное число. Определить делится ли это число на все свои цифры.
- 01.07.2017 02:25
- Информатика
- remove_red_eye 16577
- thumb_up 31
Ответы и объяснения 1
Program zadacha;
var a,b,c,d,e: integer;
begin
writeln ('Введите четырехзначное число');
readln (a);
b:=a div 1000;
c:=a div 100;
c:=c mod 10;
d:=a mod 100;
d:=d div 10;
e:=a mod 10;
if (a mod b = 0) and (a mod c = 0) and (a mod d = 0) and (a mod e = 0) then writeln ('Число делится на все свои цифры')
else writeln ('Число не делится на все свои цифры');
end.
- 02.07.2017 02:13
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.