Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА! Даю очень много баллов!
ПОЖАЛУЙСТА НЕ КОПИРУЙТЕ С ДРУГИХ САЙТОВ, ТАМ НЕ ПРАВИЛЬНО! И дочитайте текст до конца пожалуйста!
Уличный продавец получает 'a' рублей с продажи каждой из первых 50 газет. С продажи каждой из последующих газет он получает на 20% больше. Вычислите дневной заработок продавца, продающего 'k' газет в день.
НУЖНО СОСТАВИТЬ ПРОГРАММУ ПАСКАЛЬ ДЛЯ ВЫЧИСЛЕНИЯ ДНЕВНОГО ЗАРАБОТКА ПРОДАВЦА, ГДЕ 'a' И 'b' НУЖНО ВВОДИТЬ САМОЙ. Если вы не можете составить программу, то помогите пожалуйста хотя бы написать уравнение решения этой задачи, ведь тогда 'a' и 'k' остаются как есть. Пожалуйста, очень прошу помочь!
- 10.08.2018 17:55
- Информатика
- remove_red_eye 8780
- thumb_up 41
Ответы и объяснения 1
Var i,k: integer;
a,an,s: real;
begin write('стоимость газеты из первых 50: '); readln(a);
write('число проданных газет: ');
readln(k);
writeln;
if k<=50 then s:=k*a
else
begin
s:=50*a;
an:=a;
for i:=1 to k-50 do
begin
an:=an*1.2;
s:=s+an;
end;
end;
writeln('продано газет ',k,' выручка составила ',s,' руб.');
end.
- 11.08.2018 04:27
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.