Вопрос по информатике:
Дана маленькая русская буква написать программу преобразовывающая ее в большую
- 13.09.2015 16:59
- Информатика
- remove_red_eye 11728
- thumb_up 19
Ответы и объяснения 1
ScalВыделить код
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 Program lab2_2; uses crt; var s: String; n, i, b, j: longint; c: char; begin clrscr; writeln('Введите строку из заглавных букв:'); readln(s); n:=length(s); i:=1; b:=0; for j:=1 to n do begin c:=s[j]; {-----------------------------------------} b:=(ord(c))-127; {Write(b); end; } Case b of 1..9: begin Write('0'); Write(b); end; 10..33:Write(b); -95:Write('00'); else exit; end; {----------------------------------------} end; readkey; end.
- 14.09.2015 10:20
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.