Вопрос по информатике:
На паскале написать программу сокращения дроби , где N – целое, M – натуральное число. Использовать алгоритм Евклида. Разработать тесты для проверки правильности работы программы.
- 10.10.2015 17:43
- Информатика
- remove_red_eye 1126
- thumb_up 40
Ответы и объяснения 1
//Pascal ABC.NET v3.0 сборка 1111
Var
a,b,c,d:integer;
begin
read(a,b);
c:=a;
d:=b;
while (a0) and (b0) do
if a>b then a:=a mod b else b:=b mod a;
writeln(c div (a+b));
writeln('---');
writeln(d div (a+b));
end.
//А теперь программа для тестов, выведет 1000 результатов в файл
Var
a,b,c,d,i:integer;
f:text;
begin
assign(f,'text.txt');
rewrite(f);
for i:=1 to 1000 do
begin;
a:=random(1,100);
b:=random(1,100);
c:=a;
d:=b;
while (a0) and (b0) do
if a>b then a:=a mod b else b:=b mod a;
writeln(f,c,' ',c div (a+b));
writeln(f,'=':length(inttostr(c)));
writeln(f,d,' ',d div (a+b));
writeln(f);
end;
close(f);
end.
- 11.10.2015 22:49
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.