Вопрос по информатике:
Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности не ограничена). Ниже представлен рекомендуемый вид экрана во время работы программы:
*Определение максимального числа последовательности положительных чисел*
Вводите после стрелки числа. Для завершения введите ноль
- 27.06.2018 07:27
- Информатика
- remove_red_eye 8401
- thumb_up 17
Ответы и объяснения 1
Turbo Pascal:
Program readInteger;
Uses CRT;
Var s:char; z:Integer;
Begin
ClrScr;
WriteLn('Введите числа:');
repeat
If (KeyPressed = true) than
begin
S:=ReadKey
z:=z+1;
End;
Until s ="0";
Write('Вы ввели ',z,' чисел!');
ReadLn;
End.
- 28.06.2018 19:11
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.