Вопрос по информатике:
Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.
- 16.05.2018 12:46
- Информатика
- remove_red_eye 19777
- thumb_up 48
Ответы и объяснения 1
Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)
var a: integer;
begin
read(a);
if (a > 5) and (a <= 11) then
write('Утро ');
if (a > 11) and (a <= 17) then
write('День ');
if (a > 17) and (a <= 23) then
write('Вечер');
if (a = 24) or (a < 6) then
write('Ночь');
end.
- 17.05.2018 00:33
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.