Вопрос по информатике:
1. Напишите программу, которая определяет сумму цифр 3-х числа. Например : 5+4div+8=17
2. Напишите программу , которая произведение чисел 3-х
( 548 ➡️ 160)
Помогите пожалуйста
- 12.03.2018 08:48
- Информатика
- remove_red_eye 8227
- thumb_up 47
Ответы и объяснения 1
//PascalABC.Net 3.0, сборка 1053
var
n,s,p:integer;
begin
Write('Введите натуральное трехзначное число: '); Read(n);
s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
Writeln('Сумма цифр числа равна ',s);
Writeln('Произведение цифр числа равно ',p)
end.
Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160
- 13.03.2018 22:45
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.